I cannot initialize my masternode

I hope someone can help me.

When I click on the “initialize” button, I get the error message:

But my masternode is set up correctly and Syscoin-Qt is synced fully.

How can I restart my masternode?

At the moment, the “initialize” button has a bug.

You will need to use the console.

To do that

  1. Click on “Window->Console”
  2. Unlock your wallet by entering walletpassphrase [PASSPHRASE] [SECONDS]
    • replace [PASSPHRASE] with your passphrase
    • replace [SECONDS] by the number of seconds after which you want the client to lock the wallet again.
  3. Initialize your masternode by entering masternode initialize [LABEL]
    • replace [LABEL] with the name of the masternode you want to restart.
  4. Lock your wallet again by entering walletlock.

Done, should all be working now.
If it doesn’t your masternode isn’t set up correctly or your Syscoin-Qt isn’t synced fully.

Got the same outpoint error message when trying to start a MN, but unfortunately even using the console doesn’t resolve the issue for me.
On the screenshot below you can see it’s a valid masternode output, the masternode.conf is set up correctly, wallet is synced to the correct chain and I’m using the commands as described here.
Running SYS version 4.1.3

Syscoin-Qt might not have synced the governance yet. How long was this after starting it?

Just a few minutes after starting, tried a restart as part of troubleshooting to make sure the .conf took.
However, wallet says it’s fully synced, got the little checkmark in the bottom right, and if it was still syncing governance objects it would give an error instead of trying to start the node. have seen that before

Open it, wait 10 minutes, try to initialize, report back I would suggest.

It’s now been open for an hour, since my first post here, still the same error message when trying to initialize via console

In that case you either have a typo in your masternode.conf or in the syscoin.conf on that masternode.

Finally figured it out today. Everything was entered correctly, the address where the coins where was a wrong type (segwit-32)
Needed to get a new address with “getnewaddress [Name] legacy” and send the collateral there

1 Like

Thanks for reporting back :slight_smile:

I cannot restart my MN. am getting this Screen Shot 2020-05-26 at 6.29.27 PM What does it mean?

does it mean somehow there is no collateral? They are always under the padlocks

Hi @l3sny!
Welcome to the community forum :slight_smile:

You found the wrong thread. I moved your replies to the correct one. Check out my answer above.

Thx Alex, it worked!


I got the same Error Message so i initialised the MN via the console with the commands showed here.
The status of the MN than switched to ENABLED, it has this status for over 4 days now but i still dont have gotten any sys rewards?
What can i do?

It can take currently up to around 6 days before your first reward after re-init. As long as it shows ENABLED, you should be fine. Patience.

I keep getting Failed: can’t allocate outpoint when trying to initialize masternode on console.

I have checked masternode.conf and everything is correct
Everything is synced on vps and everything is synced on console
I am on the correct block height
My collateral is on the correct address address.
I checked masternode output below transaction ID and made sure config file shows the correct output.
I even tried to change that still didn’t work.

Please can somebody help initialize the masternode.

Check your masternode.conf and make sure each entry is on a single line and that you don’t have any carriage returns or other invisible characters.

Mind sharing the txid? I’d like to check that outpoint to make sure it’s copacetic.

yes config file is correct no invisible spaces. is it safe for me to share the tx id in public?

You sent the collateral, but then moved it again to a different address, then to another. The collateral has to stay at the address associated w/ that tx in order to be valid.

I think what happened is you sent multiple collateral outputs back-to-back, and did not use coin control to make sure you weren’t moving your MN collateral.

On the [Send] tab in QT you need to click the [Inputs…] button and specify which inputs you want to send from to make sure that doesn’t happen.

Once the masternodes are setup those inputs will be automatically locked (based on masternode.conf) so you won’t have to worry about accidentally moving your collateral after that.