Exchange tells me the receiving address is invalid

I just installed Syscoin core and had trouble with it syncing. I followed the posted instructions for reindexing with success. I then attempted to send some sys to this wallet and the exchange said the address is invalid. I tried creating another address got the same result. Not sure what to do…

What typeopf address is your exchange expecting you to support? And which exchangs? Not all of them support segwit.
Anything that starts witht sys1 is a bech32 (segwit) address
if it starts with sometig else you may hafe to creat a legacy address - there are instructions here, just search for them.

The exchange is ChangeNow, just using it to swap. I’m so very new to all of this and my tech skills are…none :wink: I’ll search around for the instructions to create a legacy.

if you use the qt, you can open up console and type getnewaddress "" legacy. and you’ll have a legacy address. the “” in the middle you can replace it with a label if you’d like