How to change your governance control token

Changing your Governance Control Token

Note: You need to change the token both on your masternode as well as on your local installation of Syscoin-Qt. If you have multiple masternodes, you need to use different voting tokens for each one.

1. Create a new control token

  1. Start Syscoin-Qt
  2. Open the console: Window -> Console
  3. Type: masternode genkey and press Enter for each masternode
  4. Copy the output of the command

2. Replace the control token in your local Syscoin-Qt

  1. Using a file manager, navigate to The Syscoin data directory
  2. Open masternode.conf in a simple text editor (Notepad, TextEdit,…)
  3. Find replace the string of letters and number after the masternode ip and port
    • [LABEL] [IP]:[PORT] [CONTROL_TOKEN] [COLLATERAL_ID] [COLLATERAL_OUTPUT]
  4. Save the file

3. Replace the control token on your masternode

Note: If you used the script to install your masternode, you can run this command to update your control key:
bash <(curl -sL https://raw.githubusercontent.com/syscoin/syscoin-governance-update/master/script.sh)
Note: We encourage you to never run scripts you find on the internet (including ours) without checking them beforehand.

Otherwise, if you have installed your masternode manually:

  1. Log into your masternode
  2. Navigate to your masternode’s data directory
  3. Open syscoin.conf in an editor
    • nano syscoin.conf
  4. Replace the value for masternodeprivkey with your newly generated control token
  5. Close and save the file
    • press CTRL+X
  6. Restart syscoind (or your vps if you’re unsure on how to restart syscoind)

4. Reinitialize your masternode from Syscoin-Qt

  1. Click on Window -> Console
  2. Unlock your wallet by entering walletpassphrase [PASSPHRASE] [SECONDS]
    • replace [PASSPHRASE] with your passphrase
    • replace [SECONDS] by the number of seconds after which you want the client to lock the wallet again.
  3. Initialize your masternode by entering masternode initialize [LABEL]
    • replace [LABEL] with the name of the masternode you want to restart.
  4. Lock your wallet again by entering walletlock.

please tell me the command for syscoind restarting

I rebooted the VPS. Now I get this output when I do: syscli masternode status

syscli masternode status
{
“outpoint”: “0000000000000000000000000000000000000000000000000000000000000000-4294967295”,
“service”: “5.xxx.yy.15:8369”,
“status”: “Not capable masternode: Masternode not in masternode list”

any advice ?

Make sure it is synced fully syscli mnsync status. You want it to be 999 and then re-initialize from Qt before you pay attention to the masternode status.

syscli mnsync status
{
“AssetID”: 999,
“AssetName”: “MASTERNODE_SYNC_FINISHED”,
“AssetStartTime”: 1590854410,
“Attempt”: 0,
“IsBlockchainSynced”: true,
“IsMasternodeListSynced”: true,
“IsWinnersListSynced”: true,
“IsSynced”: true,
“IsFailed”: false

and, on the QT now I get ENABLED on masternode tab. But still status not ok.

Give it a while. It should be alright.

Hey there,

Will node need to requalify again before getting rewards following this process?

Seems my QT is stuck at block 1590857409 while on vps i get block 1590858426. What shall I do ?

Yes. That means each MN will miss out on ~75 SYS. Small price to pay to keep your votes your own.

Note: Seniority not affected. Stays intact!

1 Like

no problem with the sys rewards, but need to know if I am to be watching this or it should be ok ? My VPS shows me this:
syscli masternode status
{
“outpoint”: “0000000000000000000000000000000000000000000000000000000000000000-4294967295”,
“service”: “5.181.49.15:8369”,
“status”: “Not capable masternode: Masternode not in masternode list”

and QT shows ENABLED on Masternode tab.

That sounds like your QT (controller) masternode.conf might have a misalignment or otherwise not be configured properly… or you have not updated the control token in the syscoin.conf on your masternode host (line masternodeprivkey=<controlTokenHere> )

I did redo the whole setup process, looked for spaces and all and still not working:

ON VPS I get:
syscli mnsync status
{
“AssetID”: 999,
“AssetName”: “MASTERNODE_SYNC_FINISHED”,
“AssetStartTime”: 1590862600,
“Attempt”: 0,
“IsBlockchainSynced”: true,
“IsMasternodeListSynced”: true,
“IsWinnersListSynced”: true,
“IsSynced”: true,
“IsFailed”: false
}

on QT I get

21:25:07 mnsync status

“AssetID”: 999,

“AssetName”: “MASTERNODE_SYNC_FINISHED”,

“AssetStartTime”: 1590862856,

“Attempt”: 0,

“IsBlockchainSynced”: true,

“IsMasternodeListSynced”: true,

“IsWinnersListSynced”: true,

“IsSynced”: true,

“IsFailed”: false

}

those aren’t block heights, they’re unix timestamps (seconds since 1st of January 1980).

So can you initialize the node via the console?
What does syscli masternode status say about 30 minutes after initialization?

somehow problem solved:
syscli masternode status
{
“outpoint”: “ffjshdfjsd57e1a1e46bgdifugdf876g87df6g87df2ddkfjghkdfjhgjfd2e466a-0”,
“service”: “5.xxx.yy.z5:8369”,
“payee”: “my payee”,
“status”: “Masternode successfully started”
}

I will wait for the next payment and after it will know it if is ok after all. Thanks for help guys !

Can you please provide instructions for those using Masternode Hosting providers, such as Allnodes!

I see i still get rewards now, what is the cutoff date for changing the control token before one stops receiving rewards?

Hi @MooBaa
there is no cutoff date. You will continue receiving rewards until you start with the process to change the control token, after which you’ll have to wait for the duration of the grace period.

Allnodes will be sending out instructions this week. Please wait for them to contact you.