I have sys coin 1.1.2 My syscoin is stuck. Sorry if this topic is already out there

I’m reading some other posts and I dont see how to apply this to me.

I dont have version 2, 3, or 4.
I only have 1.1.2

I jumped into this a couple of years ago thinking I could figure it out
but its complicated. I might be the slowest kid in this classroom so
please be patient with me. I’m learning. :confused:
I can provide screenshots or any info that might be useful.

Please anyone. Thanks!!


You use this guide to convert from Blockmarket to SYS4

:dizzy_face: This is a bit difficult. I think what you are saying is that I have to follow a process, as outlines in the guide, in order to work up to SYS4. Other words, I cannot just upgrade from V1.2 to sys4.

So, in the guide I noticed where you said I have to change the name of the directory
I did that, and then I went on to read about making a back up of the wallet.dat file, which I also did.
Afterwards, I open the blockmarket app. And I got an error. Long story short (for now) I went back and realized that where I renamed the sys coin directory (mac) it actually just copied the folder with all contents but left the original sys directory with its contents in the same place. I deleted the one that was renamed and the original sys coin directory remained intact.
I also copied the .dat file and put into my public folder as you said (I think)
Next I went back to open blockmarket again, this time no error, but where I would normally see my sys balance along with a lock icon, which represents the wallet i need to unlock, I see no lock icon and I see the spinning arrow telling me to wait while the blocks are loaded. This is new. This is not what I normally see when I open the app.
As of now the blocks are still loading and the sys balance along with locked wallet icon are not visible.

There seems to be a small process error in that guide which i have now corrected. It was asking to you to rename the syscoin folder before you had 1) Backed up wallet.dat and 2) carried out the dump procedure. Renaming is covered in ‘Get a Clean Start’

Do you still have a copy of the original wallet.dat. If the ‘unlock icon’ is unlocked and you set a password it is the wrong wallet.dat. BM does not need to sync

I do still have the original wallet.dat
I did rename it before the backup and the dump but before i read the ‘get a clean start’
so I dont know if that affected it.

see the screenshot? The lock or unlock icon is not there

I cannot remember what that version of BM looked like it was a long time ago.
If you are sure you have put a copy of your saved wallet.dat into the syscoin folder continue with the dumpwallet procedure from the guide. Dont delete anything for now just rename. So basically from where you are now

  1. Dumpwallet
  2. Rename syscoin folder
  3. Run up SYS4, this will create a new syscoin folder
  4. Let it sync
  5. Import the Dumpfile

Hello again. Hope life is great.
So… you see the screenshot just above, the one of my blockmarket app running on my mac? Do you see in the upper right area, there is no lock icon?

There used to be a lock, the lock is gone somehow.
I dont see anywhere that I can enter the /Users/[USERNAME]/Public/sys3dump.bmwalletdump
As indicated from the guide

Im just not seeing where to activate or execute the steps, on the blockmarket
foundry app i have.

btw… when I made the copy of the wallet.dat
the default option to open it was VLC player.
I tried opening with text edit or other word apps but even then, i didn’t know what to do with it. The blockmarket app didnt act right afterwards. Something was reeeeally wrong with it.
So i retraced my steps and “undid” everything I did, and the original file wallet.dat in the syscoin in directory moved right back to its original spot.
Then I went back to the blockmarket and tried to open it again and it opened, but now the Lock icon is gone. :frowning:

  1. If there is no lock icon you have used the wrong wallet.dat file, find the correct one and put it in /Users/[USERNAME]/Library/Application Support/Syscoin/
  2. You cannot open a wallet.dat file with an editor