Masternodes stop working after few days

Software: QT4.1.3


  • I’ve setup 2 masternodes, from 1 wallet within QT which I created new.

  • This wallet contains 200K sys, with two times 100K sys sent to collateral and being locked.

  • Setup exactly as stated in

  • 1st time: nodes were running for a few days, but then don’t generate rewards anymore.

  • 2nd time: have destroyed/reset my servers, re-run all steps (with collateral being kept at same address, same mn genkey etc.), nodes were running again for a few days, but then again don’t generate rewards anymore.

  • Within masternode status it states on both MNs NEW START REQUIRED

  • Tried to initialize them via Console, but did not helped. Goes to pre-enabled, but do not generate any rewards anymore.

  • Both two nodes run on separate servers with the appropriate configuration as stated on

  • Other nodes I run are all setup in a separate wallet, just containing per wallet only 100K collateral and are generating rewards ever since and are stable.

Anyone an idea what could possibly be wrong with those 2 which do not generate rewards?

I am comfortable sending both 2x100K to two separate wallets if necessary since seniority on these ones is just a few days.

What are the first 5 chars of the collateral address

First 5 characters: SevM2

OK thats correct
When you say no rewards for a few days you must wait about 5-6 days for your first reward did you do that

Yes sure. Took a few days, believe 5, before the rewards came. They came in for 6 days in a row and then stopped. Both nodes where paying out rewards within 1 wallet. When I look within my transaction tab, having this wallet opened up, both nodes payed out. From the 1st till the 6th day. Then they stopped paying out.

Not sure whats going on then it is unlikely to be your QT you can run unlimited MNs from 1 wallet.

Can you go to your VPS and type syscli getblockcount and let me know the results and also what is one of your VPS IPs

Result: 794072

The correct block should be 855491

On your VPS reboot them type reboot then once it is backup type

sudo service syscoind stop && sleep 5 && sudo su -c 'syscoind -reindex' syscoin

Wait 10 minute then check block count again until it matches to latest block from the explorer
Once it is correct restart your nodes from QT

Once the node starts paying again check the blockcount daily to see if it gets stuck again and let me know

I will! Thanks for your help John!

Good morning,

I’m not sure if i’m having the same issue, but i’ll explain. So my masternode requires a re start every 6 to 8 days. for some reason. i’m using allnodes to monitor my masternode & i’ve realized that after day 6 i get pings to my masternode that fail. right now its at 15 pings & my masternode is still enable, i’m pretty sure in a next few days it’ll get more pings and fail. i’ll have to manually re start my node. any reason why this is happening? what can i do to fix this issue?