PENDING loop in SPARK wallet - funds not available!


I have a problem regarding the syscoin wallet SPARK on Macos Mojave. Here’s the info on the version:

Running Syscoin 4.1.3

Here’s the history of what I’ve been doing:

  1. I installed Spark wallet and send 1 SYS to the main wallet address created by default. So far so good…
  2. I created 3 subaddresses and used a ‘dump wallet’ and a ‘backup wallet’ action.
  3. I sent a big amount of SYS to one of the generated subaddresses from two exchanges.

The problem:

Now spark wallet is in the loop with synchronizing with the status ‘pending’ since days. In the main interface it’s showing the balance of the main address of 1 SYS but that’s it. What should I do?

Thank you!


You could try a reindex. What was the purpose of doing the ‘dump wallet’ and ‘backup wallet’ instead of copying the wallet.dat?

The dump file is in plain text and can pose a security risk if not protected. I don’t know what the backup wallet command does.

I was trying to backup my wallet before sending considerable amounts to it and to be able to recover my funds in case something goes wrong. I tried to reindex by adding ‘reindex=1’ and I’m glad to say that it worked. Should I now remove ‘reindex=1’ from the syscoin.conf?

Also, any advice how I should backup in order to be able to recover my funds independent from any wallet app?


Yes remove reindex=1.

The wallet.dat file contains all your addresses and future addresses as it’s deterministic. I don’t believe future legacy addresses are stored though so if you make one of those for a masternode in the future you will need to create another backup at that time.

Once it’s password protected you should copy/paste it to multiple locations/devices. If you want a copy on the cloud so you can access it at all times you can do that as well. For extra protection you can put it in an encrypted folder.