Stuck in "another syscoin process running" error loop

I’m in the process of trying to update to the lastest software versions and have followed the guide of backing up my wallet and created a wallet dump. I have a sys2dump.bmwalletdump, and a wallet.dat file.

I had spark running but had issues importing wallet data, so I tried running the alternative QT 4.1.3, now I am stuck in an error loop.

I do have a couple of Syscoin folders on my mac (Syscoin, syscoin2 (renamed an old folder when updating), and Syscoin core.

This is the error I get.
Blockmarket v3.2.0
“We’ve detected another syscoin process running. Click on ‘Restart Syscoin Core’ to close it and continue loading Blockmarket.”

I tried removing syscoin core and have uninstalled spark, but I am still getting that error.

If someone can direct with logical next steps that would be great. i.e. uninstalling all associated SYS folders, etc.

First would need to know what version you where updating from but if you have successfully created the dumpfile and renamed the original syscoin folder to syscoin2 you should be able to run 4.1.3 and import it. Try rebooting your machine to kill any running processes

Thanks @johnp I got blockmarket to run again. Look like it’s running 3.2.0. My SYS balance is showing zero though, I’m assuming that should be correct since I did a wallet dump?

From this point should I just follow the process of installing 4.1 again?
Is it safe to uninstall blockmarket since I have a wallet backup and dump file?

Need to know what version of the software you created the dump file with

@johnp What’s the best way to find that out?
The dump file says “sys2dump.bmwalletdump” does that mean it was version 2?

From what I remember the UI of blockmarket was identical to the screenshot in my first post, but I think the loading screen and launch icon were different.

Based on the fact that you see no TXs in BM3 i would assume that you did it with BM1 so close BM3 but dont delete yet and run QT4.1.3 and let it sync then run importwallet with your dump file keeping good copies of everything