Updating from Blockmarket 1.1.0

Hey there!

Would love some wallet upgrading assistance. I purchased SYS several years back and they’re all currently on my Blockmarket Desktop 1.1.0.

Is there a guide on the best way to update to the most current wallet? I don’t want to accidentally mess things up.

If you could kindly advise me that would be wonderful! Thank you.

1 Like

Hey there!

I don’t see an option to dumpwallet from Blockmarket 1.1.0. Could you advise on how to do this? Thanks!

Also, is it possible for an old wallet to get corrupted? I tried inputting my password to unlock it and get an error message with some html tags.

Upgrade to the Blockmarket in the guide and follow the procedure from there.

Always work with a backup of your wallet for safety measures in case something is messed up along the way

sounds good, i’ll try that.

since my version of blockmarket doesn’t seem to have the walletdump option, should i upgrade to 1.2.3 and then walletdump from there?

Correct. That should work

1 Like

ok, just to double check before i do it haha

to upgrade, do i simply install Blockmarket 1.2.3 over my previous Blockmarket 1.1?

(and backup my wallet.dat)

so i successfully updated from BM 1.1 to BM 1.2.3 (2 years later lol)

i tried to wallet dump to this address:

/Users/xxxxx/Public/sys3dump.bmwalletdump (with xxxx as my username)

and i get this error message:

"error internal service error

can’t parse JSON. raw result:
-8 - cannot open wallet dump file"

any advice? thank you!

actually sorry disregard, i must have had a typo somewhere and BM did the wallet dump successfully!

another question

i downloaded and installed Syscoin Core 4 when i try to open it i get the error message:

“Error: Cannot obtain a lock on data directory /Users/xxxxx/Library/Application Support/Syscoin. Syscoin Core is probably already running.”

it still comes up after i reboot the computer - any advice? thanks much.

just a test, i installed Syscoin Core 4 on another computer to see if it would open and i get this error message now:

“Error: Incorrect or no genesis block found. Wrong datadir for network?”


Are you installing to the default directory? You can’t have other Syscoin wallets open at the same time either

yes! just installing Syscoin Core 4 into my applications folder.

on the mac with my BM 1.2.3 i get the “cannot obtain a lock on data directory”

on my other computer with no syscoin previously installed, i get the “error: incorrect or no genesis block found. wrong datadir for network”


@johnp should be able to figure this one out

thank you, not ideal but I installed Syscoin Core 4 on my bootcamp windows and it seems to be working so far, blockchain is syncing now.

i’m curious if the syscoin core 4 on mac is not working because i previously didn’t have syscoin core 3?

rror: incorrect or no genesis block found. wrong datadir for network”

You got that error because you must have loaded your saved Sys2 wallet.dat file, you cant do that
You needed to allow the new installation to create a new wallet.dat and import the dump file

This is because you had another instance running, you should not have installed Spark until you generated the dumpfile as both Sys2 and Sys4 use the 'Syscoin directory. Sys3 used ‘Syscoincore’

ah, i have the dumpfile from BM 1.2.3 - should i just uninstall my wallet completely, download Syscoin Core 4, and import the dumpfile in?

Yes as simple as that
Make sure that if you created a Syscoin folder in appdata with BM1.2.3 you rename it first, then just do a new install of Sys4, let is sync and import dumpfile