Updating from Syscoin Core version v0.13.2.0-61afb24 (64-bit)


I purchased Syscoin several years ago. It currently stored in Syscoin Core version v0.13.2.0-61afb24 (64-bit). I realize this is terribly outdated version of the wallet.

I followed upgrade instructions detailed in this Medium article https://medium.com/@bittyjohn1954/syscoin-3-conversion-from-syscoin-2-579a8cf02603

Following this procedure, I downloaded Blockmarket Version 3.2.0 ( and attempted to get it to sync up, but it did not connect (0 peers; wallet syncing message even after a week).

I then downloaded Spark 4.1.3 on another machine and attempted to sync up the wallet using the backup dat file. The wallet has synced up to the blockchain but my coins don’t show up.

The coins however continue to show up on the original Syscoin Core version v0.13.2.0-61afb24 (64-bit) wallet. Though I can’t do any operation on this wallet since all transactions go unconfirmed into the mem-pool.

I tried looking up various resources but did not find anything that shows the procedure to upgrade from Syscoin Core version v0.13.2.0-61afb24 (64-bit). I realize this is a request coming rather late in the evolution of Syscoin. My apologies.

I’d appreciate any assistance to help me recover my coins.

Best wishes,

Lester Wilfred

I’m not sure which version that is. Always keep a backup of your original wallet and work with a copy.

See if this guide works - https://medium.com/@bittyjohn1954/syscoin-4-conversion-from-syscoin-2-c32757812602

Use this https://medium.com/@bittyjohn1954/syscoin-4-conversion-from-syscoin-2-c32757812602

When you run up Sys2 QT it does not need to sync you just need to dumpwallet
On your other Machine remove the wallet.dat and let it create a new one then import the dumpfile you created from the first part of the guide.

Digging through my archive i think it’s version 2.14 :open_mouth:

Thanks c_e_d, I was wondering what the notation <<Syscoin Core version v0.13.2.0-61afb24 (64-bit)>> meant. I got this from the “about” drop down on the app on my Mac. Appreciate the support.

Hello All,

Thank you for all your suggestions. It worked! I downloaded Syscoin Core version v4.1.3.0 and followed the instructions in the recommended Medium article: https://medium.com/@bittyjohn1954/syscoin-4-conversion-from-syscoin-2-c32757812602

All my coins showed up successfully in the wallet running SysCoin Core 3.

Thank you all again.

1 Like