Urgent help. Please help me with this Pali wallet problem

I posted a message on the Syscoin telegram channel and I suspect that some scammers tried to get me to go to https://decentralised-rectify.rf.gd/?
Thankfully I didnt do this.

My problem is that I downloaded the Pali wallet extension and sent my SYS balance to there, I created a password and stored my 12 word private key.
Now when I enter my password the Pali wallet will not unlock so I tried to restore it with my 12 words but when I enter the 12 words the “Import button” wont light up and work ?

I’m really worried why this wont work and its terrible that scammers tried to con me on the Syscoin Telegram channel !

Please can you help me ? Why wont my pali wallet extension not unlock with my password and why wont it restore with my 12 words private key ?

I’m really grateful for your help and support.

Thank you

We have already discussed this by DM on Telegram when you asked me, however I will leave the answer here again.

Your problem that Pali does not unlock when you enter your unlock password is simply because you are entering the wrong password.

In the event that you finally do not remember the unlock password for Pali Wallet, you will have to import your seed phrase again to access your account again, requesting a new unlock password.

Finally, if when you enter your seeds in Pali Wallet and click Import, no account is imported, it is because one of the seeds you are entering is incorrect.

Carefully check that the seeds you are entering are correct, and remember that you must write them in lower case, separated by a space.

:warning::zap:For better support, please go to our DISCORD
» Opening of a ticket in :ticket:│create-ticket