Wallet assistance

Hi, I would like to ask for some wallet setting assistance. In 2017 I bought some sys and download qt wallet. Some year ago I tried to login, but wallet was not working anymore as it was outdated. So I tried to install a new version, but couldn’t make it worked. As I had some qt wallets for other currencies I thought I just have to replace wallet.dat as with other qt wallets. But after reading about it I realized that it is not so trivial. Anyhow, I didn’t succeed, so I would kindly like to ask if somebody can help me. I have old wallet password and wallet.dat file backed up.

1 Like

It will be one of these guides depending if you are coming from Syscoin 2 or Syscoin 3. I believe you’ll be on Syscoin 2 given the date you provided.

1 Like

Thanks for your swift reply, NerZee. The problem is that I could messed up a wallet when trying to upgrade. I remember I tried several times and got errors every time. Meanwhile I also changed hard drive (although I still have my old drive in working condition). And yes, I checked when I first bought sys and it was in May 2017 and my last purchase was in December 2017. All my sys are in stored in wallet, so I used sys 2 wallet. Is it possible to download latest version of sys 2 wallet and try to restore it? As obviously I have to have sys 2 wallet set up before I can proceed with procedure in manual you sent me.

Always work with a copy of your original wallet.dat backup. The one you were trying with earlier might be corrupted now, so use a fresh one of your backup. Follow the guides exactly and things should work out :+1: Let me know how it goes.

Thanks. I’ll try tomorrow. Wish me luck :slightly_smiling_face:.

It looks like I’m stuck at “C:\Users\Public\sys2dump.bmwalletdump” command (using win 10).

Method not found (code -32601)

I think I did exactly as manual instructing. Here are my steps:

  1. downloaded and installed Syscoin 2.1.6 wallet
  2. replaced installed wallet.dat (located in …appdata/roaming/syscoin) with my backed up wallet.dat
  3. opened Syscoin 2.1.6
  4. opened console and copied C:\Users\Public\sys2dump.bmwalletdump into consoles input box
  5. pressed enter
  6. checked my C:\Users\Public folder…nothing there

Am I doing something wrong?

You forgot to type the dumpwallet command. You need to enter this entire line from the guide into the console:

dumpwallet “C:\Users\Public\sys2dump.bmwalletdump”

1 Like

Ah, ok. Thanks. Manual doesn’t say that though. I tried and got another error:

Error: Please enter the wallet passphrase with walletpassphrase first. (code -13)

I have browsed through wallet menus, but somehow I can’t find where to enter passphrase. Is it Settings/Encrypt wallet? It is currently disabled. Or do I have to change existing passphrase in order to enable Encrypt wallet option?

It does say that in the manual.

You need your wallet unlocked in order to dump it as well. Whatever password you used to encrypt the wallet you have is needed.

Oh, stupid me. I apologize, you’re right of course. I was looking at procedure for BM 1.2.3, instead of Syscoin 2.1.6. Will try again. Sorry again for bothering you because of my ignorance.

Ok, I think I’m mostly done here. Wallet is syncing. This should take a while I guess. Then I just need to import sys2dump file, transfer my coins to a newly created address and that’s it. Thank you for all your help, NerZee. To be honest, beside manual you sent, I shouldn’t need additional assistance, as manual instructions are very clear. So I’m a little embarrassed now, lol. Thanks again and take care.

1 Like

Same here, I’m back from 2017. Followed the tutorials. Exported my wallet from Blockmarket 1.2.3 (on an old Mac Mini).
And now I’m trying to import the .bmwalletdump in Blockmarket 3.1.3.
But I get the Error: “Request failed with status code 401”
Anyone here knows what can be wrong?
Thanks in advance!