Wallet.dat - Syscoincore can not read the wallet


I wanted to creat my 1st masternode, unfortunatelly I have coppied configuration string from Allnodes and past it under last bottom line in to wallet.dat instead to masternode.conf. At once delete this line, but unfortunatelly I have save the file.
Now Syscoincore can’t work, because of the problem with read the wallet.dat.
What should I do?

Thank you in advance

Do you have a backup copy of your wallet.dat?

Unfortunatelly I didn’t do that.

@johnp I’ve never seen this problem before. Any idea what to do?

Well if he has edited his wallet.dat i think thats it
Unless someone else knows different

What about a wallet dump? Recovery of private keys, copy them and past to the new wallet?
Might it work?

I don’t know enough about this subject. The wallet.dat might be damaged or useless now. I would make a copy of it before you try a wallet dump to retrieve private keys. Do you happen to see any other wallet.dat files that backed up automatically?

I have already made few copies of my wallet befor doing a dump.
Did anyone had the same issue?

I’ve never heard of anybody editing their wallet.dat. The risk is that your file is now corrupted and can’t be used to access your funds. Normally this is fine because proper backups have been made and you can just use those. If you have no backup from before you edited your wallet.dat it might be bad news.

What about of make a scan of my wallet using pywallet and find the private keys? There is a many cases with bitcoin wallets, does it work also for syscoin?

Syscoin shares Bitcoin code so it might work

Well if you have a good copy before doing the dump procedure just us that copy to dump again into a new wallet

do you know a good procedure, I could use?

You said you had made copies before doing a dump
So Use that wallet you created the dump file with in the version of Syscoin you had (2 or 3)and replace the wallet.dat with your saved one then do an import into a new 4.1.3 wallet

yes I do, but that are the copies of corrupted wallet. Syscoin core dosen’t work.

Ok been playing around with a wallet.dat to try and break it like yours, and when i added an extra line and saved it QT would not read it. I then removed the line and saved it but QT still didnt load it.
What i found was that if i saved it with the cursor and the end of the last good line it worked. Try that

Did you opened it in Notepad or in some another txt. file editor?
I tried the same with new wallet and dosen’t work? May I send you my wallet?

That is completely up to you, bear in mind you will be taking a risk as you would need to trust me not to run off with your funds. If you choose to do this send it by Direct message, here or in Discord, do not post it in an open forum, click on my name and choose message. There are no guarantees that i can do anything.