I can't see my aliases in Spark

After migrating from blockmarket 2 to 3, my alias is no longer visible on the wallet. After migrating to the spark wallet, I don’t even know where to find if my alias still exists. Is it possible for any of you to remove my alias and for my funds to be returned to my wallet?

Aliases are currently not a feature of Syscoin. All your funds should be available though.
Have you followed any of these guides?

Yes, I did as in the instructions. In blockmarket 3 I could search for my alias, I knew it was. There was a permanent message next to it: 'This Alias’s identity data has not yet been migrated to Blockchain Foundry’s new identity service. Basic view shown. 'The balance from the alias was not visible on my wallet. I tried to install, uninstall different versions of wallets, still nothing. I would add that I extended ‘life’ of my alias by a few years.
Instead of over 2000 syscoin on my wallet I have 0.73.
I was trying to get help on a slack. Unfortunately, no one could help me.

Well, it seems like you did a lot of other things besides what the instructions said. Based on your description so far it’s impossible to determine what went wrong.
Can you provide a more detailed account of the steps you took, in order, ideally with a report of what status you could perceive at any point?

Before callisto? airdrop I created an alias because it was a requirement. I then decided to extend the validity of my alliance so I did it. Later another version of blockmarket appeared. From what I remember, I was switching from version 1 to 3. And here the problem already occurred, my alias ceased to be visible. So I installed the second version. Alias ​​was still not visible. I installed the first version again, the second and the third version with the staff I did dump wallet. I have several backups of my wallet, the oldest is from 2017. (wallet.dat)

  1. Aliases no longer exist on the Syscoin Network, and previous version 2 and 3 chains are no longer running, therefore you will not see your alias on any Syscoin wallet. There will be a new Identity Layer in the future.

  2. Your coins will still be at the same addresses you had in Versions 2,3 or 4. You will need to DUMPWALLET and IMPORTWALLET into version 4.1.3. (Instructions attached above) You will not see correct balances on old wallets because they can not sync with a network that is not running. Once you have imported your keys into 4.1.3 and synced, your coins will appear.

  3. You should be able to migrate directly from 2 to 4 using the dumpwallet, importwallet procedure.

Thank you for your answer. I made a dumpwallet (file) from version 1, 2 and 3. Unfortunately, after importing wallet my coins sent to my alias are not visible.
‘You should be able to migrate directly from 2 to 4 using the dumpwallet, importwallet procedure.’

I just did that. Unfortunately, the coins sent to the alias are not visible.

It might be interesting to look at what happened in a block explorer. I’d start with the address that holds the 0.73 sys.

(no label)
(no label)

What results are you expecting?
If you don’t see those SYS in your wallet, go to console and enter:

getaddressinfo SYF2FFHBKrUHcuScLHCboj1EuJ17Tqf8Zs


getaddressinfo SdLSr2TatqqokahtvhpwpsmzMoqkPp7g2N

if “ismine”: is false, then you do not own the addresses.

None of these addresses had any movement on Sys4 or Sys3.
I don’t have a Sys2 chain that I could check, so I guess this is where the rabbit hole ends.

Thank you. So my coins are stuck on the sys2 chain? Oddly, because I did a dump wallet with blockmarket 2 also.

No coins are stuck on Sys2, they were all transferred to Sys3 and then to Sys4.

If the coins were on one of these two addresses, they were moved away in Sys2…but we don’t know that because we don’t have the Sys2 blockchain.

The most likely chain of events is that you created a backup of your sys2 wallet, then moved the coins to that wallet, and are now trying to restore them from a backup that doesn’t contain them…because back in those days Syscoin wallets were not Hierarchically Deterministic and you weren’t able to restore keys generated after backup from that backup.

The other possibility is that you, or someone else with access to your private keys, moved the coins to an address not in your wallet.

All the coins, when I checked the blockmarket were on my alias: szuvax. Nobody but me has access to this wallet.

You said you had to search for that alias in the list of all aliases.

That suggests you don’t have the private key controlling it in your wallet.

? so what is a dump file, if not the private key?
I was looking there because the funds from the alias were not imported into my wallet (thats the problem of this topic) and I wanted to see if the alias still exists.

Aliases were names associated with a private/public key pair. They were deprecated with Sys4. Syscoins, then and now are associated with the private/public key pair. So when everyone lost their Aliases due to the network deprecating them, nobody lost their Syscoin. Those remain associated with the private/public key pair. @Keyare already told you as much here.

A dump file is a text file containing the private keys present in the wallet at the time of creating it.
For modern versions of Syscoin, it also contains the cryptographic seed from which private keys are generated.

So if you create dump files from your wallets and import them into Syscoin-Qt 4 successfully and you wait for it to sync, and it still doesn’t show your coins, that means the private keys controlling the coins weren’t in your wallet.

This can be due to two things: Either the coins moved from a keypair in your wallet to a keypair not in your wallet, or you have an old backup of a non-HD wallet that didn’t yet contain the keypair that you sent the coins to (and created the alias for).

In either case, you lost control over the coins.

Hey. I have a question because I have processed all the instructions on how to switch from Blockmarket 1.2.3 wallet to Syscoin wallet 4.x.x., and unfortunately I do not have access to the funds. The only thing I see is constantly updating the 2019 transactions on the Blockmarket wallet. In Syscoin Wallet I see this transaction in history but the tokens are not visible in the balance. What can I do to get them in my wallet and have access to them?