QT wallet not syncing, no peers

Hi, using QT 4.1.3 - wallet not syncing, and there are no peers available. How to get wallet syncing again?

please have a look at this: How to get a client to sync
Sorry for the inconvenience.

Hi Einalex.

I’ve followed the steps outlined to reindex, the wallet did sync.
However, 48 hours later it will not sync, again. Why is this happening repeatedly? Is there is a bug in 4.1.3 (windows)? It hasn’t happened with previous wallets. Or, are there any peer node address that can be copied into a syscoin.conf file to help this? This has worked with other wallets.

In your link “How to get a client to sync”, Step 3 suggests to rename the Syscoin data directory. When I’ve tried this a dialogue box appears saying client will download the bitcoin blockchain and sync all the way back to 2009 - is there a more convenient fix?


Hi Are,

There is a bug in recent versions of Syscoin that sometimes leads to a wallet not recognizing that it is on a forked chain. In that situations the wallet will mistake all the nodes telling it about the proper chainhead for malicious actors and bans them, hence why the sync stops. This can happen repeatedly, but it is quite rare for wallets that are fully synced to fall prey to this bug.

That error message you got upon trying to sync is a bit overblown as the Syscoin 4 blockchain is only just over a year old (we made a snapshot of the state of the Syscoin 3 chain at that point and started with a new chain. The text is an artifact of our bitcoin heritage…it hasn’t been replaced yet :wink:
So you don’t have to worry, the client will not download the bitcoin blockchain, but the syscoin one, and only since last year.
The more convenient fix is reindexing, if it works.


It is back and forth, sometimes it will sync others it will not. I was trying to sync through a VPN, it didn’t work. VPN off, synced. I don’t know.