Update troubles

hi all, i am trying to recover my syscoins, i had blockmarket whit a password that i saved and i have a backup and i had a backup of the wallet. now i tried to open the blockmarket but it gave a javascript error, so i backupped all the blockmarket folder and i installed the last version of blockmarket on the old one, it worket, but it didn’t ask me my password and i don’t see my syscoin. I tried then to import the old wallet and dump it and i did the guide steps to import the dumped wallet in syscon 4, at the end i was successfull but still my syscoin are zero, even after the sync, now i don’t know what i can do. I know my pubblic address if needed

1 Like

Hi Luigi!
Welcome to the Community Wiki :slight_smile:

From your description, I don’t yet know exactly which steps you performed, so I will ask a few questions to try and clear up the picture.

  • What was that javascript error? (You can attach screenshots here, if you have one)
  • What do you mean by “on the old one” ?
  • “I tried then to import the old wallet and dump it”. How did you import the old wallet into what?

Let’s see if we can’t help you :slight_smile:

1 Like

the old installation of blockmarket, i installed the latest version over it, but before i saved the blockmarket folder.

following the guide for the dump and the import exactly

the point now is that given the datas i have we have to see it i can recover my syscoin, i have the old dat, the password for blockmarket and the pubblik key

no sorry that wasn’t the Js error, i give you the correct picture here:

Did you check for the things asked in the first error message?
That the wallet is unlocked and that it can write to the chosen location?

I haven’t seen the second one before. So you got the second error first, and then afterwards the first error? Both with the original blockmarket installation, which still shows your balance correctly?

And after you installed the lastest version of blockmarket, it’s using the same “SyscoinCore” data directory with the same content, but it’s not asking you for a password when trying to dump the private keys?

The blockmarket installation gave that javascript error and didn’t open.
Then i reinstalled blockmarket (and i saved the blockmarket folder to be safe).
No syscoin appeared.
Then i put in blockmarket the old dat backup file, no syscoin appeared but i dumped the wallet following the guide. I then impprted it corrrectly in the new syscoin wallet but no syscoin appear. I hope to be clear this time!

Thanks, that is very helpful :slight_smile:

Did the new blockmarket installation ask you for the password you used in the old one, when creating the dumpfile? If so, the dump made should be that of the keys in the old wallet.dat. If not, the replacement didn’t work for some reason and you dumped the keys in the newly created wallet.dat.

it didn’t ask my password

can i give you my wallet dat and see if you can recover it? (in private obviously)

Let’s try and fix the problem without exposing your private keys first :wink:

In what folder did you copy your old wallet.dat to replace the new one?

I listed the data directory locations in The Syscoin data directory

you mean to replace in blockmarket? i did import wallet menu

Hm, no idea what that does. I suggest you close blockmarket, copy your wallet.dat into the Syscoin data directory as per the link in my last reply…You want the Syscoin 3 version… and then start blockmarket again and try to dump the private keys again. If it asks you for the password, that worked.

can you please link syscoin 3?

Blockmarket is a Syscoin3 client :wink:
I mean this:

/Users/[USERNAME]/Library/Application Support/SyscoinCore/
Note : The Library directory is hidden by default, you can quickly access this directory by opening Finder
pressing: CMD + Shift + G
and typing: ~/Library/Application Support/SyscoinCore/

i know, i meant if you can give me the download link

To Syscoin-Qt 3?

I’m not sure if the data directories are compatible between Blockmarket and Qt. I never could run Blockmarket on my Linux system :wink:

now when i open syscoin 3 it tells me wallet is corrupted, i put the wallet i backupped from blockmarket, as i told you

yes. I’d try with the blockmarket that worked before…not sure why you wanted to avoid that.

what do i want to avoid??